Error: Secure Connection Failed


#1

Hi,

I don’t know whats wrong here, trying to access:

https://korni-app-165.opscaptain.com/

will give me :
"Secure Connection Failed

An error occurred during a connection to korni-app-165.opscaptain.com.

The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
Please contact the website owners to inform them of this problem." 

What to do here ?


#2

That is wierd, can you send a screen shot. Thanks. I clicked on the link and it said the endpoint did not send any data. Typically when this happens your application is not listening on the environment variable PORT which is typically set to 3000


#3

This time tried to deploy again(meanwhile i was deleting the repository on github, because I thought it doesn’t work anyway and nobody is responding …).

I was using https://github.com/Urigo/angular-meteor-base, just to test, I was pushing this project to my repository and did the deployment again.

I got(log):

I got(log):
... Modules Converted to TypeScript.: 4.534ms Emitting All Impls: 346.700ms Modules Analyzed.: 742.926ms Filtering TypeScript source files: 0.071ms Angular Compiler Program Created.: 101.205ms Angular Compiler Host Created.: 0.048ms TypeScript Program Created.: 880.412ms TypeScript Host Created.: 0.085ms [client]: Collecting TypeScript source files: 4.111ms [client]: SCSS Files Compilation: 0.748ms [client]: HTML Files Compilation: 6.365ms [client]: TypeScript Files Compilation: 3007.669ms Modules Converted to TypeScript.: 12.702ms Emitting All Impls: 378.458ms Modules Analyzed.: 1199.945ms Filtering TypeScript source files: 0.061ms Angular Compiler Program Created.: 164.763ms Angular Compiler Host Created.: 0.348ms TypeScript Program Created.: 1357.925ms TypeScript Host Created.: 0.327ms [client]: Collecting TypeScript source files: 2.888ms Browserslist: caniuse-lite is outdated. Please run next commandnpm update caniuse-lite browserslist`
-----> Building Meteor app with ROOT_URL: https://korni-app-165.ospcaptain.com/
found 0 vulnerabilities
added 382 packages from 1048 contributors and audited 2976 packages in 10.094s
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.8: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“x64”})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.8 (node_modules/fsevents):
Chromium downloaded to /bundle/ocapphome/node_modules/puppeteer/.local-chromium/linux-641577

node install.js
puppeteer@1.14.0 install /bundle/ocapphome/node_modules/puppeteer
-----> and npm: 6.4.1
-----> Using node: v8.11.4
-----> Checking if this meteor version supports --server-only
-----> Target Meteor version: Meteor 1.8.0.1
-----> Existing meteor installation found, using it.
-----> Cloning into ‘.’…
-----> Cloning into ‘.’…
-----> Detect project type as buildpack not explicitly specified
-----> Upload [ ] 0%
-----> Cloning into ‘.’…
-----> Using Git respository myusername/urigo and branch master
----> Begin deployment on container host with ID (1)`

=> actually, I wanted to paste the entrire Log, but it says there is not enough space

=> “Exited (1) 4 minutes ago” (status, dashboard)
(hope nothing too private in here)

Trying to connect ( https://korni-app-165.opscaptain.com/ ), will result in :

Secure Connection Failed

An error occurred during a connection to korni-app-165.opscaptain.com.

The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
Please contact the website owners to inform them of this problem.

Thanks for helping


#4

checking it out at the moment


#5

Issue should be fixed. Basically it was building the project with both the horse buildpack and node.js buildpack since there is a package.json in the root. We have made it such that if a meteor.js project is detected, ignore the package.json file and only use the meteor.js buildpack. To avoid auto detection, you can always just specify the buildpack you want.


#6

Thank you :slight_smile:


#7

Where to save API-Keys ?


#8

Environment variables. Under the App details section.


#9

same error again …


#10

This is the error i am seeing which is different from the previous error. Did you attempt to set ROOT_URL variable or something?

Error: Must pass options.rootUrl or set ROOT_URL in the server environment
at Object.Meteor.absoluteUrl (packages/meteor.js:1448:11)
at runWebAppServer (packages/webapp/webapp_server.js:762:18)
at webapp_server.js (packages/webapp/webapp_server.js:1163:1)
at fileEvaluate (packages/modules-runtime.js:336:7)
at Module.require (packages/modules-runtime.js:238:14)
at require (packages/modules-runtime.js:258:21)
at /bundle/ocapphome/.meteor/heroku_build/app/programs/server/packages/webapp.js:1579:15
at /bundle/ocapphome/.meteor/heroku_build/app/programs/server/packages/webapp.js:1588:3
at /bundle/ocapphome/.meteor/heroku_build/app/programs/server/boot.js:411:36
at Array.forEach ()
at /bundle/ocapphome/.meteor/heroku_build/app/programs/server/boot.js:220:19
at /bundle/ocapphome/.meteor/heroku_build/app/programs/server/boot.js:471:5
at Function.run (/bundle/ocapphome/.meteor/heroku_build/app/programs/server/profile.js:510:12)
at /bundle/ocapphome/.meteor/heroku_build/app/programs/server/boot.js:470:11
/bundle/ocapphome/.meteor/heroku_build/app/programs/server/boot.js:475
}).run();


#11

Anyways, should be resolved. We are setting it automatically when you attempt to update environment variables and it is not already set.


#12

How to upload and delete file, photos on the server using meteor ?


#13

From our end, you can upload files to this directory on the server “/oc-app-data”. For how to go about doing that in Meteor.js, i think you should reference the Meteor.js documentation or their developer forums.


#14

Where to access the environment variable, which I save on your site ?


#15

I am assuming you want to access it at runtime. You can use the below code. Assuming you have set the variable “SOME_API_KEY”, you can access it in your code as:

process.env.SOME_API_KEY